update subversion on OS X 10.10 Yosemite

I upgraded my OS from Mavericks to Yosemite, however then wanted to upgrade subversion from 1.7 to 1.8, port install subversion always returned error

Here is how to fix it:

Download latest MacPort for Yosemite https://distfiles.macports.org/MacPorts/MacPorts-2.3.3-10.10-Yosemite.pkg

After latest macport, then run port install subversion again,

Bingo, that’s it!

more to add:

make sure cleanup old dependent version also

port uninstall apr

port uninstall apr-util

then port install subversion